Jump to content

Template:Cite IETF/doc

From Elite Dangerous Wiki
Revision as of 11:50, 24 September 2026 by Wikipedia>GKNishimoto (Undid revision 1158692041 by GKNishimoto (talk))
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

__EXPECTED_UNCONNECTED_PAGE__

This is a template to cite IETF documents[1][2] including:

Usage

This template supports most of the parameters available to {{Citation}}. For information about those parameters see that template's documentation.

Note: All parameter names must be in lowercase.

Cite IETF specific parameters

  • |appendix= – Appendix number of the document. |appendix=A.1 produces "sec. A.1" Also used to create an anchor link for the document's URL.
  • |autolink= – |autolink=yes or |autolink=no Automatically generate a link to ietf.org for documents specified with |rfc=, |std=, |bcp=, |fyi=, |draft=, |ien=, or |rtr=. (enabled by default)
  • |bcp= – Number of the Best Current Practice (BCP) document. Also used to automatically generate a link to ietf.org.
  • |draft= – Name of the Internet Draft (I-D) document, including the leading draft-. Also used to automatically generate a link to ietf.org.
  • |fyi= – Number of the For Your Information (FYI) document. Also used to automatically generate a link to ietf.org.
  • |idanchor= – Anchor link target. By default, no anchor link is generated. The special value |idanchor=ietf generates an anchor link suitable for use with this template's |ref= parameter. Requires one of |id=, |rfc=, |std=, |bcp=, |fyi=, |draft=, |ien= or |rtr= fields to be present for the anchor link text.
  • |idlink= – Internal document anchor or title of a Wikipedia article to link via the document identifier. Article should already exist. Must not be wikilinked itself. Do not use this on its own, but along with |id=, |rfc=, |std=, |bcp=, |fyi=, |draft=, |ien= or |rtr=.
  • |idlinktype= – One of the values: |id=, |rfc=, |std=, |bcp=, |fyi=, |draft=, |ien= or |rtr= can be given to |idlinktype= to force the template to use the specified document identifier as the link text for |idanchor= or |idlink=. Do not use this on its own, but along with |idanchor= or |idlink= and |id=, |rfc=, |std=, |bcp=, |fyi=, |draft=, |ien= or |rtr=.
  • |ien= – Number of the Internet Experiment Note (IEN) document. Also used to automatically generate a link to ietf.org.
  • |nosec= – Using |section=, |sections=, or |appendix= automatically places the sec. notation. Se |nosec=y to hide the sec. notation.
  • |referenceid= – Reference id for the document. Used to create an anchor link for the document's URL.
  • |rfc= – Number of the Request for Comments (RFC) document. Also used to automatically generate a link to ietf.org.
  • |rtr= – Number of the RARE Technical Reports (RTR) document. Also used to automatically generate a link to ietf.org.
  • |section= – Section number of the document. |section=4.3.1 produces "sec. 4.3.1" Also used to create an anchor link for the document's URL. Can also be used in combination with |sections= to link to the first section in the given section range.
  • |sections= – Section range of the document. |sections=4.3-4.7 produces "sec. 4.3–4.7"
  • |sectionname= – The section name or section title of the document, written in full; displays before |title= and enclosed in quotes.
  • |std= – Number of the Internet Standard (STD) document. Also used to automatically generate a link to ietf.org.
  • |style= – Override the style of link used for RFC and Internet Draft. Effective values are "html" (default for RFC), "text" (default for Internet Draft).

As with all cs1|2 templates, |title= is required. If omitted, the template will attempt to auto-generate a title using the first of |rfc=, |std=, |bcp=, |fyi=, |draft=, |ien=, |rtr= or |id= document identifier parameters, in that order.

Copy a blank version to use. Remember to use the "|" (pipe) character between each parameter. Please delete any unused parameters to avoid clutter in the edit window.

Full version (copy and paste text below and delete parameters you don't need)
{{Cite IETF |title= |rfc= |std= |bcp= |fyi= |draft= |ien= |rtr= |sectionname= |section= |sections= |appendix= |referenceid= |page= |pages= |last1= |first1= |authorlink1= |last2= |first2= |authorlink2= |authormask= |editor1-last= |editor1-first= |editor1-link= |others= |date= |year= |orig-date= |publisher=[[Internet Engineering Task Force|IETF]] |location= |language= |format= |access-date= |url= |section-url= |page-url= |autolink= |id= |idanchor= |idlink= |idlinktype= |doi= |doi-broken-date= |issn= |archive-url= |archive-date= |quote= |nopp= |nosec= |ref= |postscript= |last-author-amp= |style=}}
Most commonly used parameters (use this and you won't have to delete as much)
{{Cite IETF |title= |rfc= |sectionname= |section= |page= |last= |first= |author-link= |date= |publisher=[[Internet Engineering Task Force|IETF]] |access-date= |doi=}}
Example 1
{{Cite IETF |title=The Tao of IETF: A novice's guide to the Internet Engineering Task Force |rfc=4677 |fyi=17 |last1=Hoffman |first1=P. |authorlink1=Paul Hoffman (engineer) |last2=Harris |first2=S. |date=September 2006 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=October 20, 2009 |doi=10.17487/RFC4677}}

Hoffman, P.; Harris, S. (September 2006). The Tao of IETF: A novice's guide to the Internet Engineering Task Force. IETF. doi:10.17487/RFC4677. FYI 17. RFC 4677. Retrieved October 20, 2009.

Example 2
{{Cite IETF |title=Telnet protocol specification |rfc=854 |std=8 |sectionname=Are you there (AYT) |page=8 |last1=Postel |first1=J. |author-link1=Jon Postel |last2=Reynolds |first2=J. |author-link2=Joyce K. Reynolds |date=May 1983 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=October 20, 2009 |doi=10.17487/RFC0854 }}

Postel, J.; Reynolds, J. (May 1983). "Are you there (AYT)". Telnet protocol specification. IETF. p. 8. doi:10.17487/RFC0854. STD 8. RFC 854. Retrieved October 20, 2009.

Examples

  • {{Cite IETF |title=JSON |rfc=7159 |sectionname=IANA considerations |section=11 |author=T. Bray |authorlink=Tim Bray |date=March 2014 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=November 26, 2017 |doi=10.17487/RFC7159 }}
    → T. Bray (March 2014). "IANA considerations". JSON. IETF. sec. 11. doi:10.17487/RFC7159. RFC 7159. Retrieved November 26, 2017.
  • {{Cite IETF |title=Hypertext transfer protocol -- HTTP/1.1 |rfc=2616 |first1=R. |last1=Fielding |authorlink1=Roy Fielding |first2=J. |last2=Gettys |authorlink2=Jim Gettys |first3=J. |last3=Mogul |first4=H. |last4=Frystyk |authorlink4=Henrik Frystyk Nielsen |first5=L. |last5=Masinter |first6=P. |last6=Leach |first7=T. |last7=Berners-Lee |authorlink7=Tim Berners-Lee |date=June 1999 |publisher=[[Internet Engineering Task Force|IETF]] |doi=10.17487/RFC2616 }}
    → Fielding, R.; Gettys, J.; Mogul, J.; Frystyk, H.; Masinter, L.; Leach, P.; Berners-Lee, T. (June 1999). Hypertext transfer protocol -- HTTP/1.1. IETF. doi:10.17487/RFC2616. RFC 2616.
  • {{Cite IETF |title=Domain names - concepts and facilities |rfc=1034 |sectionname=Name space specifications and terminology |section=3.1 |author=P. Mockapetris |authorlink=Paul Mockapetris |date=November 1987 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=August 3, 2008|doi=10.17487/RFC1034 |quote=A domain is a subdomain of another domain if it is contained within that domain. This relationship can be tested by seeing if the subdomain's name ends with the containing domain's name. For example, A.B.C.D is a subdomain of B.C.D, C.D, D, and ' '. }}
    → P. Mockapetris (November 1987). "Name space specifications and terminology". Domain names - concepts and facilities. IETF. sec. 3.1. doi:10.17487/RFC1034. RFC 1034. Retrieved August 3, 2008. A domain is a subdomain of another domain if it is contained within that domain. This relationship can be tested by seeing if the subdomain's name ends with the containing domain's name. For example, A.B.C.D is a subdomain of B.C.D, C.D, D, and ' '.

Technical notes

Regression testing

Regression tests are available here:

Subtemplates

{{Cite IETF}} uses the following subtemplates:

URL generation

Request for Comments (RFC), For Your Information (FYI), and Internet Draft (I-D) documents are stored by https://datatracker.ietf.org/doc/html/ and are linked in the following way:

https://datatracker.ietf.org/doc/html/rfc<document number> (only if |Style]= is not "html" or "empty")
https://datatracker.ietf.org/doc/fyi<document number>
https://datatracker.ietf.org/doc/html/draft-<draft name> (only if |Style= is "text" or empty)

Request for Comments (RFC), Internet Standard (STD), Best Current Practice (BCP), Internet Experiment Note (IEN), and RARE Technical Reports (RTR) documents are stored by https://rfc-editor.org and are linked in the following way:

https://www.rfc-editor.org/rfc/rfc<document number> (only if |Style= is "html" or "empty")
https://www.rfc-editor.org/info/std<document number>
https://www.rfc-editor.org/info/bcp<document number>
https://rfc-editor.org/in-notes/ien/ien<document number>.txt
https://rfc-editor.org/in-notes/museum/RAREreports/rtr<document number>.txt

The HTML rendering of Internet Draft (I-D) pages can be requested via |Style=html (technically any value that is not empty or "text"). This produces the following URL:

https://www.ietf.org/archive/id/<draft name>.html

This URL provides a pretty HTML rendering for newer I-D documents, but returns 404 Not Found for the older files.

URL anchor generation

Anchors are generated for the URL using four parameters:

|section=number generates #section-<number>
|appendix=number generates #appendix-<number>
|referenceid=id generates #ref-<id>
|page=number generates #page-<number>

The template will give priority to the first of the parameters: |section=, |appendix=, |referenceid=, or |page= in this order and create an anchor using the first matching parameter.

See also

  • {{Ref RFC}} – pre-populated citations
  • {{IETF RFC}} – direct links to RFCs

References

Further reading

Template:Cite IETF invokes Module:Navbox using Lua.

Usage

This template can be used to make a standard navigation box. It is intended for use within another template that standardises the title and contents of the box (see Template:ShipNavbox). This template SHOULD NOT be used directly within articles, as it creates a maintenance burden to do so whenever the contents of the box have to be updated.

The purpose of this template is to standardise the attributes of all navigation boxes, for example, their colours and other CSS attributes. The template is fairly simple, and could be extended to add other features in the future. Using this template allows changes to be implemented much quicker and easier than editing each template separately.

Syntax

{{navbox
|state      = uncollapsed, collapsed, plain, autocollapse (default)
|name       = mandatory - name of the template
|style      = optional - style for the whole table
|title      = mandatory - navbox header
|gtitleN    = optional - title of N-th group of items
|styleN     = optional - style for groupN; i.e. text-align
|groupN     = mandatory - list of groups of items
|fstyle     = optional - style for footer ; i.e. text-align
|footer     = optional - navbox footer
}}
  • Groups: Currently there is no technical limit to the maximum number of groups.
    • Groups of items can be added as parameters: group1, group2, group3, ... up to groupN.
  • Group title: Each group has its own title parameter: gtitle1, gtitle2, gtitle3, ... up to gtitleN. Note that the default width for the first column is 15%.
  • Group style: Style may also be customised to each group in: style1, style2, style3, ... up to styleN.
    • Note that neither the title nor the items have any wiki-links built into the template. As a result, users of the template are free to use wiki-links as they wish.
  • Line breaks: Line-breaks (<br />) are unnecessary, as text wrapping is done automatically by the template. This also includes links and text in gtitleN and groupN.
  • Bullets: Create unordered lists with lines beginning with *.
  • Pipe links: Because of the nature of template syntax, it may be necessary to use Template:! ({{!}}).

States

  • Autocollapse: By default, the state of a navbox is "autocollapsed". This means that if the number of navboxes in a page exceeds the maximum allocation of the collapsible navboxes, then the remaining navboxes are collapsed automatically. For more information (or to change the setting), see MediaWiki:Common.js.
    • Currently, the autocollapse allocation is 2 (see MediaWiki:Common.js). This means that if there are 3 navboxes in a page, the third and subsequent navboxes will be collapsed automatically.
  • Uncollapsed: Forces the navbox to be displayed.
    • All of the navboxes in this documentation are in the uncollapsed state.
  • Collapsed: The reverse of uncollapsed. Forces the navbox to be hidden instead.
    • Navboxes with a height of more than 300 pixels will also be collapsed automatically. For more information (or to change the setting), see MediaWiki:Common.js.
  • Plain: Removes the "show/hide" link.

Sub-groups

  • For larger navboxes, it may be necessary to include sub-groups within a particular group of items. It is also possible to collapsible navboxes within the parent navbox, see Collapsible sub-groups.
  • To create sub-groups within {{navbox}}, certain parameters are to be included:
    • The parent navbox group (i.e. group2 in the example below) requires the type parameter (gtype2 = Subgroup).
    • The nested navbox (sub-group) requires the inclusion of the sub-group parameter (subgroup = yes). This enables the template to differentiate between the sub-group and the parent navbox.
{{navbox
|name    =
|title   =
|gtitle1 =
|group1  =
|gtitle2 =  
|gtype2  = Subgroup (mandatory)
|group2  = 
  {{navbox
  |subgroup = yes (mandatory)
  |gtitle1  = 
  |group1   =
  |gtitle2  = 
  |group2   = 
  }}
}}

Collapsible sub-groups

  • For extremely long navboxes, it is recommended to use collapsible navboxes within the parent navbox. Further sub-groups can then be added to these collapsible navboxes.
  • To create collapsible sub-groups within {{navbox}}, these parameters need to be included:
    • The parent navbox is almost always uncollapsed (state=uncollapsed).
    • The parent navbox group (i.e. group1 in the example below) requires the type parameter (gtype1 = Subgroup).
    • The nested collapsible navbox requires the inclusion of the collapsible parameter (collapsible = yes). This enables the template to differentiate between the collapsible navbox and the parent navbox.
    • The nested collapsible navbox is forcefully collapsed (state=collapsed).
{{navbox
|state  = uncollapsed
|name   = 
|gtype1 = Subgroup
|group1 = 
  {{navbox
  |collapsible = yes
  |state   = collapsed
  |title   = 
  |gtitle1 = 
  |group1  = 
  |gtitle2 = 
  |group2  = 
  }}
}}

Use of images

  • The use of images in navboxes is permitted, but please resize the images to keep them small. Inventory-sized images (25-30 pixels) are recommended.
  • Please use {{t|plink}} to create links with images. Use {{t|plink}} for any case where text is not desired after the link. It functions the same as {{t|plink}}, but it does not produce a wikilink in text. Use {{t|chatl}} to link chatheads. These templates create links for both the image and text (except for {{t|plink}}) using far less wikicode than the standard syntax.

Link and file share the same name

{{plink|Item}}

File name differs from the link

{{plink|Item|File}}

Link and file share the same name, but different text is desired to display

{{plink|Item|alt=Text}}

File name differs from the link and different text is desired to display

{{plink|Item|File|alt=Text}}

Categorising

Navboxes are very useful for transcluding categories onto a large number of pages that share both a trait and the navigation box. For example: Template:ShipNavbox transcludes Category:Ships onto every page that uses it.

There are 2 methods of categorising pages with navboxes:

The first way is with {{t|Ctg}}. This is the preferred method, and can be used in most cases. The rules and operations for the Category handler template are very simple; however, they are enough to produce the desired results on most pages.

Categorisation should only be used on a template for large-scale addition. It is unhelpful, for example, to use a rule that only applies to 1 page.

Examples

To see the following navboxes in action, see Template:Navbox.

Single line navbox with centered list

{{navbox
|name    = 
|title   = 
|style1  = text-align:center
|group1  =
}}
{{navbox
|name    = 
|title   = 
|gtitle1 = 
|group1  = 
|footer  = Centered footer
}}
{{navbox
|name    = 
|title   = 
|gtitle1 = 
|group1  = 
|fstyle  = text-align:right
|footer  = Right-aligned footer
}}

Multiple line navbox

{{navbox
|name    = 
|title   = 
|gtitle1 = Group title 1
|group1  = 
|gtitle2 = Group title 2
|group2  = 
|gtitle3 = Group title 3
|group3  = 
}}

Collapsed navbox

{{navbox
|state   = collapsed
|name    = 
|title   = 
|style1  = text-align:center
|group1  = 
}}

Plain navbox with Tnavbar

{{navbox
|state   = plain
|name    = 
|title   = 
|style1  = text-align:center
|group1  = 
}}

Plain navbox without Tnavbar

{{navbox
|state   = plain
|title   = 
|style1  = text-align:center
|group1  = 
}}

Complicated navbox

{{navbox
|state   = uncollapsed
|name    = 
|title   = 
|gtitle1 = Level 1 Title 1
|group1  = 
|gtitle2 = Level 1 Title 2
|group2  = 
|gtitle3 = Level 1 Title 3
|group3  = 
|gtitle4 = Level 1 Title 4
|group4  = 
|gtitle5 = Level 1 Title 5
|gtype5  = Subgroup
|group5  = 
  {{navbox
  |subgroup = Yes
  |gtitle1  = Level 2 Title 1
  |group1   =
  |gtitle2  = Level 2 Title 2
  |group2   =
  |gtitle3  = Level 2 Title 3
  |gtype3   = Subgroup
  |group3   = 
    {{navbox
    |subgroup = Yes
    |gtitle1  = Level 3 Title 1
    |group1   =
    |gtitle2  = Level 3 Title 2
    |group2   =
    }}
  |gtitle4  = Level 2 Title 4
  |group4   = 
  }}
|gtitle6 = Level 1 Title 6
|group6  = 
|gtitle7 = Level 1 Title 7
|group7  = 
|fstyle  = 
|footer  = 
}}

Preventing unwanted documentation

The Navbox template's documentation is automatically transcluded under the navbox on any Template namespace page. It is not transcluded when used as a sub-group or collapsible sub-group template (subgroup= yes or collapsible=yes).

Should the documentation appear when it is unwanted, it can be hidden by setting the doc parameter doc=no on the template. In most cases, the doc parameter is NOT used and the parameter is removed completely.


Template:Cite IETF invokes Module:Navbox using Lua.

Usage

This template can be used to make a standard navigation box. It is intended for use within another template that standardises the title and contents of the box (see Template:ShipNavbox). This template SHOULD NOT be used directly within articles, as it creates a maintenance burden to do so whenever the contents of the box have to be updated.

The purpose of this template is to standardise the attributes of all navigation boxes, for example, their colours and other CSS attributes. The template is fairly simple, and could be extended to add other features in the future. Using this template allows changes to be implemented much quicker and easier than editing each template separately.

Syntax

{{navbox
|state      = uncollapsed, collapsed, plain, autocollapse (default)
|name       = mandatory - name of the template
|style      = optional - style for the whole table
|title      = mandatory - navbox header
|gtitleN    = optional - title of N-th group of items
|styleN     = optional - style for groupN; i.e. text-align
|groupN     = mandatory - list of groups of items
|fstyle     = optional - style for footer ; i.e. text-align
|footer     = optional - navbox footer
}}
  • Groups: Currently there is no technical limit to the maximum number of groups.
    • Groups of items can be added as parameters: group1, group2, group3, ... up to groupN.
  • Group title: Each group has its own title parameter: gtitle1, gtitle2, gtitle3, ... up to gtitleN. Note that the default width for the first column is 15%.
  • Group style: Style may also be customised to each group in: style1, style2, style3, ... up to styleN.
    • Note that neither the title nor the items have any wiki-links built into the template. As a result, users of the template are free to use wiki-links as they wish.
  • Line breaks: Line-breaks (<br />) are unnecessary, as text wrapping is done automatically by the template. This also includes links and text in gtitleN and groupN.
  • Bullets: Create unordered lists with lines beginning with *.
  • Pipe links: Because of the nature of template syntax, it may be necessary to use Template:! ({{!}}).

States

  • Autocollapse: By default, the state of a navbox is "autocollapsed". This means that if the number of navboxes in a page exceeds the maximum allocation of the collapsible navboxes, then the remaining navboxes are collapsed automatically. For more information (or to change the setting), see MediaWiki:Common.js.
    • Currently, the autocollapse allocation is 2 (see MediaWiki:Common.js). This means that if there are 3 navboxes in a page, the third and subsequent navboxes will be collapsed automatically.
  • Uncollapsed: Forces the navbox to be displayed.
    • All of the navboxes in this documentation are in the uncollapsed state.
  • Collapsed: The reverse of uncollapsed. Forces the navbox to be hidden instead.
    • Navboxes with a height of more than 300 pixels will also be collapsed automatically. For more information (or to change the setting), see MediaWiki:Common.js.
  • Plain: Removes the "show/hide" link.

Sub-groups

  • For larger navboxes, it may be necessary to include sub-groups within a particular group of items. It is also possible to collapsible navboxes within the parent navbox, see Collapsible sub-groups.
  • To create sub-groups within {{navbox}}, certain parameters are to be included:
    • The parent navbox group (i.e. group2 in the example below) requires the type parameter (gtype2 = Subgroup).
    • The nested navbox (sub-group) requires the inclusion of the sub-group parameter (subgroup = yes). This enables the template to differentiate between the sub-group and the parent navbox.
{{navbox
|name    =
|title   =
|gtitle1 =
|group1  =
|gtitle2 =  
|gtype2  = Subgroup (mandatory)
|group2  = 
  {{navbox
  |subgroup = yes (mandatory)
  |gtitle1  = 
  |group1   =
  |gtitle2  = 
  |group2   = 
  }}
}}

Collapsible sub-groups

  • For extremely long navboxes, it is recommended to use collapsible navboxes within the parent navbox. Further sub-groups can then be added to these collapsible navboxes.
  • To create collapsible sub-groups within {{navbox}}, these parameters need to be included:
    • The parent navbox is almost always uncollapsed (state=uncollapsed).
    • The parent navbox group (i.e. group1 in the example below) requires the type parameter (gtype1 = Subgroup).
    • The nested collapsible navbox requires the inclusion of the collapsible parameter (collapsible = yes). This enables the template to differentiate between the collapsible navbox and the parent navbox.
    • The nested collapsible navbox is forcefully collapsed (state=collapsed).
{{navbox
|state  = uncollapsed
|name   = 
|gtype1 = Subgroup
|group1 = 
  {{navbox
  |collapsible = yes
  |state   = collapsed
  |title   = 
  |gtitle1 = 
  |group1  = 
  |gtitle2 = 
  |group2  = 
  }}
}}

Use of images

  • The use of images in navboxes is permitted, but please resize the images to keep them small. Inventory-sized images (25-30 pixels) are recommended.
  • Please use {{t|plink}} to create links with images. Use {{t|plink}} for any case where text is not desired after the link. It functions the same as {{t|plink}}, but it does not produce a wikilink in text. Use {{t|chatl}} to link chatheads. These templates create links for both the image and text (except for {{t|plink}}) using far less wikicode than the standard syntax.

Link and file share the same name

{{plink|Item}}

File name differs from the link

{{plink|Item|File}}

Link and file share the same name, but different text is desired to display

{{plink|Item|alt=Text}}

File name differs from the link and different text is desired to display

{{plink|Item|File|alt=Text}}

Categorising

Navboxes are very useful for transcluding categories onto a large number of pages that share both a trait and the navigation box. For example: Template:ShipNavbox transcludes Category:Ships onto every page that uses it.

There are 2 methods of categorising pages with navboxes:

The first way is with {{t|Ctg}}. This is the preferred method, and can be used in most cases. The rules and operations for the Category handler template are very simple; however, they are enough to produce the desired results on most pages.

Categorisation should only be used on a template for large-scale addition. It is unhelpful, for example, to use a rule that only applies to 1 page.

Examples

To see the following navboxes in action, see Template:Navbox.

Single line navbox with centered list

{{navbox
|name    = 
|title   = 
|style1  = text-align:center
|group1  =
}}
{{navbox
|name    = 
|title   = 
|gtitle1 = 
|group1  = 
|footer  = Centered footer
}}
{{navbox
|name    = 
|title   = 
|gtitle1 = 
|group1  = 
|fstyle  = text-align:right
|footer  = Right-aligned footer
}}

Multiple line navbox

{{navbox
|name    = 
|title   = 
|gtitle1 = Group title 1
|group1  = 
|gtitle2 = Group title 2
|group2  = 
|gtitle3 = Group title 3
|group3  = 
}}

Collapsed navbox

{{navbox
|state   = collapsed
|name    = 
|title   = 
|style1  = text-align:center
|group1  = 
}}

Plain navbox with Tnavbar

{{navbox
|state   = plain
|name    = 
|title   = 
|style1  = text-align:center
|group1  = 
}}

Plain navbox without Tnavbar

{{navbox
|state   = plain
|title   = 
|style1  = text-align:center
|group1  = 
}}

Complicated navbox

{{navbox
|state   = uncollapsed
|name    = 
|title   = 
|gtitle1 = Level 1 Title 1
|group1  = 
|gtitle2 = Level 1 Title 2
|group2  = 
|gtitle3 = Level 1 Title 3
|group3  = 
|gtitle4 = Level 1 Title 4
|group4  = 
|gtitle5 = Level 1 Title 5
|gtype5  = Subgroup
|group5  = 
  {{navbox
  |subgroup = Yes
  |gtitle1  = Level 2 Title 1
  |group1   =
  |gtitle2  = Level 2 Title 2
  |group2   =
  |gtitle3  = Level 2 Title 3
  |gtype3   = Subgroup
  |group3   = 
    {{navbox
    |subgroup = Yes
    |gtitle1  = Level 3 Title 1
    |group1   =
    |gtitle2  = Level 3 Title 2
    |group2   =
    }}
  |gtitle4  = Level 2 Title 4
  |group4   = 
  }}
|gtitle6 = Level 1 Title 6
|group6  = 
|gtitle7 = Level 1 Title 7
|group7  = 
|fstyle  = 
|footer  = 
}}

Preventing unwanted documentation

The Navbox template's documentation is automatically transcluded under the navbox on any Template namespace page. It is not transcluded when used as a sub-group or collapsible sub-group template (subgroup= yes or collapsible=yes).

Should the documentation appear when it is unwanted, it can be hidden by setting the doc parameter doc=no on the template. In most cases, the doc parameter is NOT used and the parameter is removed completely.


This template produces COinS metadata; see COinS in Wikipedia for background information.