<?xml version="1.0"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="en-GB">
	<id>https://elite.mistflux.co.uk/w/index.php?action=history&amp;feed=atom&amp;title=Template%3ACite_IETF%2Fdoc</id>
	<title>Template:Cite IETF/doc - Revision history</title>
	<link rel="self" type="application/atom+xml" href="https://elite.mistflux.co.uk/w/index.php?action=history&amp;feed=atom&amp;title=Template%3ACite_IETF%2Fdoc"/>
	<link rel="alternate" type="text/html" href="https://elite.mistflux.co.uk/w/index.php?title=Template:Cite_IETF/doc&amp;action=history"/>
	<updated>2026-11-01T03:14:42Z</updated>
	<subtitle>Revision history for this page on the wiki</subtitle>
	<generator>MediaWiki 1.46.2</generator>
	<entry>
		<id>https://elite.mistflux.co.uk/w/index.php?title=Template:Cite_IETF/doc&amp;diff=132244&amp;oldid=prev</id>
		<title>Wikipedia&gt;GKNishimoto: Undid revision 1158692041 by GKNishimoto (talk)</title>
		<link rel="alternate" type="text/html" href="https://elite.mistflux.co.uk/w/index.php?title=Template:Cite_IETF/doc&amp;diff=132244&amp;oldid=prev"/>
		<updated>2026-09-24T11:50:55Z</updated>

		<summary type="html">&lt;p&gt;Undid revision &lt;a href=&quot;/wiki/Special:Diff/1158692041&quot; title=&quot;Special:Diff/1158692041&quot;&gt;1158692041&lt;/a&gt; by &lt;a href=&quot;/wiki/Special:Contributions/GKNishimoto&quot; title=&quot;Special:Contributions/GKNishimoto&quot;&gt;GKNishimoto&lt;/a&gt; (&lt;a href=&quot;/w/index.php?title=User_talk:GKNishimoto&amp;amp;action=edit&amp;amp;redlink=1&quot; class=&quot;new&quot; title=&quot;User talk:GKNishimoto (page does not exist)&quot;&gt;talk&lt;/a&gt;)&lt;/p&gt;
&lt;p&gt;&lt;b&gt;New page&lt;/b&gt;&lt;/p&gt;&lt;div&gt;{{Documentation subpage}}&lt;br /&gt;
&amp;lt;!-- Please, add categories where indicated at the bottom of this page. --&amp;gt;&lt;br /&gt;
{{CS1 wrapper |type=source |base=citation }}&lt;br /&gt;
{{Lua|Module:Citation mode|Module:Template wrapper}}&lt;br /&gt;
This is a template to cite [[Internet Engineering Task Force|IETF]] documents&amp;lt;ref&amp;gt;{{Cite IETF |title=The Tao of IETF: A novice&amp;#039;s guide to the Internet Engineering Task Force |rfc=4677 |fyi=17 |last1=Hoffman |first1=Paul |authorlink1=Paul Hoffman (engineer) |last2=Harris |first2=Susan |date=September 2006 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=November 2, 2009 |doi=10.17487/RFC4677 }}&amp;lt;/ref&amp;gt;&amp;lt;ref&amp;gt;{{Cite IETF |title=A primer on Internet and TCP/IP tools |rfc=1739 |sectionname=Internet documentation |section=4 |last1=Kessler |first1=Gary C. |last2=Shepard |first2=Steven D. |date=December 1994 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=November 2, 2009 |doi=10.17487/RFC1739 |ref=ietf }}&amp;lt;/ref&amp;gt; including:&lt;br /&gt;
* [[Request for Comments]] (RFC)&amp;lt;ref&amp;gt;{{Cite IETF |rfc=1739 |title=A primer on Internet and TCP/IP tools |sectionname=Request for comments (RFCs) |section=4.1 |pages=36–38 |idanchor=ietf }}&amp;lt;/ref&amp;gt;&lt;br /&gt;
* [[For Your Information]] (FYI)&amp;lt;ref&amp;gt;{{Cite IETF |title=F.Y.I. on F.Y.I.: Introduction to the F.Y.I. notes |rfc=1150 |fyi=1 |last1=Malkin |first1=Gary Scott |last2=Reynolds |first2=Joyce K. |authorlink2=Joyce K. Reynolds |date=March 1990 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=November 2, 2009 |doi=10.17487/RFC1150 }}&amp;lt;/ref&amp;gt;&amp;lt;ref&amp;gt;{{Cite IETF |rfc=1739 |title=A primer on Internet and TCP/IP tools |sectionname=For your information documents |section=4.3 |page=39 |idanchor=ietf }}&amp;lt;/ref&amp;gt;&lt;br /&gt;
* [[Internet Draft]] (I-D)&lt;br /&gt;
* [[Internet Standard]] (STD)&amp;lt;ref&amp;gt;{{Cite IETF |title=The Internet standards process -- Revision 3 |rfc=2026 |bcp=9 |last=Bradner |first=Scott O. |authorlink=Scott Bradner |date=October 1996 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=November 2, 2009 |doi=10.17487/RFC2026 }}&amp;lt;/ref&amp;gt;&amp;lt;ref&amp;gt;{{Cite IETF |rfc=1739 |title=A primer on Internet and TCP/IP tools |sectionname=Internet standards |section=4.2 |pages=38–39 |idanchor=ietf }}&amp;lt;/ref&amp;gt;&lt;br /&gt;
* [[Best current practice]] (BCP)&amp;lt;ref&amp;gt;{{Cite IETF |title=Best current practices |rfc=1818 |bcp=1 | last1=Postel |first1=Jon |authorlink1=Jon Postel |last2=Rekhter |first2=Yakov |authorlink2=Yakov Rekhter |last3=Li |first3=Tony |date=August 1995 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=November 2, 2009 |doi=10.17487/RFC1818 }}&amp;lt;/ref&amp;gt;&lt;br /&gt;
* [[Internet Experiment Note]] (IEN)&lt;br /&gt;
* [[Réseaux Associés pour la Recherche Européenne|RARE]] Technical Reports (RTR)&amp;lt;ref&amp;gt;{{Cite IETF |rfc=1739 |title=A primer on Internet and TCP/IP tools |sectionname=RARE technical reports |section=4.4 |page=40 |idanchor=ietf }}&amp;lt;/ref&amp;gt;&lt;br /&gt;
&lt;br /&gt;
{{TOC limit|3}}&lt;br /&gt;
&lt;br /&gt;
== Usage ==&lt;br /&gt;
&lt;br /&gt;
This template supports most of the parameters available to {{Tlx|Citation}}.  For information about those parameters see that template&amp;#039;s documentation.&lt;br /&gt;
&lt;br /&gt;
&amp;#039;&amp;#039;&amp;#039;&amp;#039;&amp;#039;Note&amp;#039;&amp;#039;&amp;#039;&amp;#039;&amp;#039;: All parameter names {{strong|must}} be in [[lowercase]].&lt;br /&gt;
&lt;br /&gt;
=== Cite IETF specific parameters ===&lt;br /&gt;
* {{Para|appendix}} – Appendix number of the document. {{Para|appendix|A.1}} produces &amp;quot;sec. A.1&amp;quot; Also used to create an anchor link for the document&amp;#039;s URL.&lt;br /&gt;
* {{Para|autolink}} – {{Para|autolink|&amp;lt;var&amp;gt;yes&amp;lt;/var&amp;gt;}} or {{Para|autolink|&amp;lt;var&amp;gt;no&amp;lt;/var&amp;gt;}} Automatically generate a link to ietf.org for documents specified with {{Para|rfc}}, {{Para|std}}, {{Para|bcp}}, {{Para|fyi}}, {{Para|draft}}, {{Para|ien}}, or {{Para|rtr}}. (enabled by default)&lt;br /&gt;
* {{Para|bcp}} – Number of the [[Best Current Practice]] (BCP) document. Also used to automatically generate a link to ietf.org.&lt;br /&gt;
* {{Para|draft}} – Name of the [[Internet Draft]] (I-D) document, including the leading draft-. Also used to automatically generate a link to ietf.org.&lt;br /&gt;
* {{Para|fyi}} – Number of the [[For Your Information]] (FYI) document. Also used to automatically generate a link to ietf.org.&lt;br /&gt;
* {{Para|idanchor}} – Anchor link target. By default, no anchor link is generated. The special value {{Para|idanchor|ietf}} generates an anchor link suitable for use with this template&amp;#039;s {{Para|ref}} parameter. Requires one of {{Para|id}}, {{Para|rfc}}, {{Para|std}}, {{Para|bcp}}, {{Para|fyi}}, {{Para|draft}}, {{Para|ien}} or {{Para|rtr}} fields to be present for the anchor link text.&lt;br /&gt;
* {{Para|idlink}} – Internal document anchor or title of a Wikipedia article to link via the document identifier. Article should already exist. Must not be wikilinked itself. Do not use this on its own, but along with {{Para|id}}, {{Para|rfc}}, {{Para|std}}, {{Para|bcp}}, {{Para|fyi}}, {{Para|draft}}, {{Para|ien}} or {{Para|rtr}}.&lt;br /&gt;
* {{Para|idlinktype}} – One of the values: {{Para|id}}, {{Para|rfc}}, {{Para|std}}, {{Para|bcp}}, {{Para|fyi}}, {{Para|draft}}, {{Para|ien}} or {{Para|rtr}} can be given to {{Para|idlinktype}} to force the template to use the specified document identifier as the link text for {{Para|idanchor}} or {{Para|idlink}}. Do not use this on its own, but along with {{Para|idanchor}} or {{Para|idlink}} and {{Para|id}}, {{Para|rfc}}, {{Para|std}}, {{Para|bcp}}, {{Para|fyi}}, {{Para|draft}}, {{Para|ien}} or {{Para|rtr}}.&lt;br /&gt;
* {{Para|ien}} – Number of the [[Internet Experiment Note]] (IEN) document. Also used to automatically generate a link to ietf.org.&lt;br /&gt;
* {{Para|nosec}} – Using {{Para|section}}, {{Para|sections}}, or {{Para|appendix}} automatically places the sec. notation. Se {{Para|nosec|y}} to hide the sec. notation.&lt;br /&gt;
* {{Para|referenceid}} – Reference id for the document. Used to create an anchor link for the document&amp;#039;s URL.&lt;br /&gt;
* {{Para|rfc}} – Number of the [[Request for Comments]] (RFC) document. Also used to automatically generate a link to ietf.org.&lt;br /&gt;
* {{Para|rtr}} – Number of the [[Réseaux Associés pour la Recherche Européenne|RARE]] Technical Reports (RTR) document. Also used to automatically generate a link to ietf.org.&lt;br /&gt;
* {{Para|section}} – Section number of the document. {{para|section|4.3.1}} produces &amp;quot;sec. 4.3.1&amp;quot; Also used to create an anchor link for the document&amp;#039;s URL. Can also be used in combination with {{Para|sections}} to link to the first section in the given section range.&lt;br /&gt;
* {{Para|sections}} – Section range of the document. {{Para|sections|4.3-4.7}} produces &amp;quot;sec. 4.3–4.7&amp;quot;&lt;br /&gt;
* {{Para|sectionname}} – The section name or section title of the document, written in full; displays before {{Para|title}} and enclosed in quotes.&lt;br /&gt;
* {{Para|std}} – Number of the [[Internet Standard]] (STD) document. Also used to automatically generate a link to ietf.org.&lt;br /&gt;
* {{Para|style}} – Override the style of link used for RFC and Internet Draft. Effective values are &amp;quot;html&amp;quot; (default for RFC), &amp;quot;text&amp;quot; (default for Internet Draft).&lt;br /&gt;
&lt;br /&gt;
As with all cs1|2 templates, {{Para|title}} is required.  If omitted, the template will attempt to auto-generate a title using the first of {{Para|rfc}}, {{Para|std}}, {{Para|bcp}}, {{Para|fyi}}, {{Para|draft}}, {{Para|ien}}, {{Para|rtr}} or {{Para|id}} document identifier parameters, in that order.&lt;br /&gt;
&lt;br /&gt;
Copy a blank version to use. Remember to use the &amp;quot;|&amp;quot; (pipe) character between each parameter. Please delete any unused parameters to avoid clutter in the edit window.&lt;br /&gt;
&lt;br /&gt;
{| class=&amp;quot;wikitable&amp;quot;&lt;br /&gt;
|-&lt;br /&gt;
! colspan=&amp;quot;3&amp;quot; | Full version (copy and paste text below and delete parameters you don&amp;#039;t need)&lt;br /&gt;
|- width=&amp;quot;50%&amp;quot; style=&amp;quot;vertical-align:top;&amp;quot;&lt;br /&gt;
| colspan=&amp;quot;3&amp;quot; |&lt;br /&gt;
:&amp;lt;syntaxhighlight lang=&amp;quot;wikitext&amp;quot;&amp;gt;{{Cite IETF |title= |rfc= |std= |bcp= |fyi= |draft= |ien= |rtr= |sectionname= |section= |sections= |appendix= |referenceid= |page= |pages= |last1= |first1= |authorlink1= |last2= |first2= |authorlink2= |authormask= |editor1-last= |editor1-first= |editor1-link= |others= |date= |year= |orig-date= |publisher=[[Internet Engineering Task Force|IETF]] |location= |language= |format= |access-date= |url= |section-url= |page-url= |autolink= |id= |idanchor= |idlink= |idlinktype= |doi= |doi-broken-date= |issn= |archive-url= |archive-date= |quote= |nopp= |nosec= |ref= |postscript= |last-author-amp= |style=}}&amp;lt;/syntaxhighlight&amp;gt;&lt;br /&gt;
|- width=&amp;quot;50%&amp;quot; style=&amp;quot;vertical-align:top;&amp;quot;&lt;br /&gt;
! colspan=&amp;quot;3&amp;quot; | Most commonly used parameters (use this and you won&amp;#039;t have to delete as much)&lt;br /&gt;
|- width=&amp;quot;50%&amp;quot; style=&amp;quot;vertical-align:top;&amp;quot;&lt;br /&gt;
| colspan=&amp;quot;3&amp;quot; |&lt;br /&gt;
:&amp;lt;syntaxhighlight lang=&amp;quot;wikitext&amp;quot;&amp;gt;{{Cite IETF |title= |rfc= |sectionname= |section= |page= |last= |first= |author-link= |date= |publisher=[[Internet Engineering Task Force|IETF]] |access-date= |doi=}}&amp;lt;/syntaxhighlight&amp;gt;&lt;br /&gt;
|- width=&amp;quot;50%&amp;quot; style=&amp;quot;vertical-align:top;&amp;quot;&lt;br /&gt;
! Example 1&lt;br /&gt;
| style=&amp;quot;vertical-align: top;&amp;quot; |&lt;br /&gt;
&amp;lt;syntaxhighlight lang=&amp;quot;wikitext&amp;quot;&amp;gt;{{Cite IETF |title=The Tao of IETF: A novice&amp;#039;s guide to the Internet Engineering Task Force |rfc=4677 |fyi=17 |last1=Hoffman |first1=P. |authorlink1=Paul Hoffman (engineer) |last2=Harris |first2=S. |date=September 2006 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=October 20, 2009 |doi=10.17487/RFC4677}}&amp;lt;/syntaxhighlight&amp;gt;&lt;br /&gt;
| style=&amp;quot;vertical-align: top;&amp;quot; |&lt;br /&gt;
{{Cite IETF |title=The Tao of IETF: A novice&amp;#039;s guide to the Internet Engineering Task Force |rfc=4677 |fyi=17 |last1=Hoffman |first1=P. |author-link1=Paul Hoffman (engineer) |last2=Harris |first2=S. |date=September 2006 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=October 20, 2009 |doi=10.17487/RFC4677}}&lt;br /&gt;
|- width=&amp;quot;50%&amp;quot; style=&amp;quot;vertical-align:top;&amp;quot;&lt;br /&gt;
! Example 2&lt;br /&gt;
| style=&amp;quot;vertical-align: top;&amp;quot; |&amp;lt;syntaxhighlight lang=&amp;quot;wikitext&amp;quot;&amp;gt;{{Cite IETF |title=Telnet protocol specification |rfc=854 |std=8 |sectionname=Are you there (AYT) |page=8 |last1=Postel |first1=J. |author-link1=Jon Postel |last2=Reynolds |first2=J. |author-link2=Joyce K. Reynolds |date=May 1983 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=October 20, 2009 |doi=10.17487/RFC0854 }}&amp;lt;/syntaxhighlight&amp;gt;&lt;br /&gt;
| style=&amp;quot;vertical-align: top;&amp;quot; |&lt;br /&gt;
{{Cite IETF |title=Telnet protocol specification |rfc=854 |std=8 |sectionname=Are you there (AYT) |page=8 |last1=Postel |first1=J. |author-link1=Jon Postel |last2=Reynolds |first2=J. |author-link2=Joyce K. Reynolds |date=May 1983 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=October 20, 2009 |doi=10.17487/RFC0854 }}&lt;br /&gt;
|}&lt;br /&gt;
&lt;br /&gt;
== Examples ==&lt;br /&gt;
&lt;br /&gt;
* &amp;lt;syntaxhighlight lang=&amp;quot;wikitext&amp;quot; inline&amp;gt;{{Cite IETF |title=JSON |rfc=7159 |sectionname=IANA considerations |section=11 |author=T. Bray |authorlink=Tim Bray |date=March 2014 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=November 26, 2017 |doi=10.17487/RFC7159 }}&amp;lt;/syntaxhighlight&amp;gt;&lt;br /&gt;
*:→ &amp;lt;span style=&amp;quot;background:white&amp;quot;&amp;gt;{{Cite IETF |title=JSON |rfc=7159 |sectionname=IANA considerations |section=11 |author=T. Bray |authorlink=Tim Bray |date=March 2014 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=November 26, 2017 |doi=10.17487/RFC7159 }}&amp;lt;/span&amp;gt;&lt;br /&gt;
* &amp;lt;syntaxhighlight lang=&amp;quot;wikitext&amp;quot; inline&amp;gt;{{Cite IETF |title=Hypertext transfer protocol -- HTTP/1.1 |rfc=2616 |first1=R. |last1=Fielding |authorlink1=Roy Fielding |first2=J. |last2=Gettys |authorlink2=Jim Gettys |first3=J. |last3=Mogul |first4=H. |last4=Frystyk |authorlink4=Henrik Frystyk Nielsen |first5=L. |last5=Masinter |first6=P. |last6=Leach |first7=T. |last7=Berners-Lee |authorlink7=Tim Berners-Lee |date=June 1999 |publisher=[[Internet Engineering Task Force|IETF]] |doi=10.17487/RFC2616 }}&amp;lt;/syntaxhighlight&amp;gt;&lt;br /&gt;
*:→ &amp;lt;span style=&amp;quot;background:white&amp;quot;&amp;gt;{{Cite IETF |title=Hypertext transfer protocol -- HTTP/1.1 |rfc=2616 |first1=R. |last1=Fielding |authorlink1=Roy Fielding |first2=J. |last2=Gettys |authorlink2=Jim Gettys |first3=J. |last3=Mogul |first4=H. |last4=Frystyk |authorlink4=Henrik Frystyk Nielsen |first5=L. |last5=Masinter |first6=P. |last6=Leach |first7=T. |last7=Berners-Lee |authorlink7=Tim Berners-Lee |date=June 1999 |publisher=[[Internet Engineering Task Force|IETF]] |doi=10.17487/RFC2616 }}&amp;lt;/span&amp;gt;&lt;br /&gt;
* &amp;lt;syntaxhighlight lang=&amp;quot;wikitext&amp;quot; inline&amp;gt;{{Cite IETF |title=Domain names - concepts and facilities |rfc=1034 |sectionname=Name space specifications and terminology |section=3.1 |author=P. Mockapetris |authorlink=Paul Mockapetris |date=November 1987 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=August 3, 2008|doi=10.17487/RFC1034 |quote=A domain is a subdomain of another domain if it is contained within that domain. This relationship can be tested by seeing if the subdomain&amp;#039;s name ends with the containing domain&amp;#039;s name. For example, A.B.C.D is a subdomain of B.C.D, C.D, D, and &amp;#039; &amp;#039;. }}&amp;lt;/syntaxhighlight&amp;gt;&lt;br /&gt;
*:→ &amp;lt;span style=&amp;quot;background:white&amp;quot;&amp;gt;{{Cite IETF |title=Domain names - concepts and facilities |rfc=1034 |sectionname=Name space specifications and terminology |section=3.1 |author=P. Mockapetris |authorlink=Paul Mockapetris |date=November 1987 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=August 3, 2008&lt;br /&gt;
|doi=10.17487/RFC1034 |quote=A domain is a subdomain of another domain if it is contained within that domain. This relationship can be tested by seeing if the subdomain&amp;#039;s name ends with the containing domain&amp;#039;s name. For example, A.B.C.D is a subdomain of B.C.D, C.D, D, and &amp;#039; &amp;#039;. }}&amp;lt;/span&amp;gt;&lt;br /&gt;
&lt;br /&gt;
== Technical notes ==&lt;br /&gt;
&lt;br /&gt;
=== Regression testing ===&lt;br /&gt;
&lt;br /&gt;
[[Regression testing|Regression tests]] are available here:&lt;br /&gt;
&lt;br /&gt;
* {{Tl|Cite IETF/regression tests}}&lt;br /&gt;
&lt;br /&gt;
=== Subtemplates ===&lt;br /&gt;
&lt;br /&gt;
{{Tl|Cite IETF}} uses the following subtemplates:&lt;br /&gt;
&lt;br /&gt;
* {{Tl|Cite IETF/doctypes}}&lt;br /&gt;
* {{Tl|Cite IETF/makelink}}&lt;br /&gt;
* {{Tl|Cite IETF/refanchor}}&lt;br /&gt;
&lt;br /&gt;
===URL generation===&lt;br /&gt;
&lt;br /&gt;
[[Request for Comments]] (RFC), [[For Your Information]] (FYI), and [[Internet Draft]] (I-D) documents are stored by &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://datatracker.ietf.org/doc/html/&amp;lt;/nowiki&amp;gt;&amp;lt;/code&amp;gt; and are linked in the following way:&lt;br /&gt;
&lt;br /&gt;
: &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://datatracker.ietf.org/doc/html/rfc&amp;lt;/nowiki&amp;gt;&amp;lt;var&amp;gt;&amp;lt;document number&amp;gt;&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt; (only if {{para|Style]}} is not &amp;quot;html&amp;quot; or &amp;quot;empty&amp;quot;)&lt;br /&gt;
: &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://datatracker.ietf.org/doc/fyi&amp;lt;/nowiki&amp;gt;&amp;lt;var&amp;gt;&amp;lt;document number&amp;gt;&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt;&lt;br /&gt;
: &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://datatracker.ietf.org/doc/html/draft-&amp;lt;/nowiki&amp;gt;&amp;lt;var&amp;gt;&amp;lt;draft name&amp;gt;&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt; (only if {{para|Style}} is &amp;quot;text&amp;quot; or empty)&lt;br /&gt;
&lt;br /&gt;
[[Request for Comments]] (RFC), [[Internet Standard]] (STD), [[Best Current Practice]] (BCP),  [[Internet Experiment Note]] (IEN), and [[Réseaux Associés pour la Recherche Européenne|RARE]] Technical Reports (RTR)  documents are stored by &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://rfc-editor.org&amp;lt;/nowiki&amp;gt;&amp;lt;/code&amp;gt; and are linked in the following way:&lt;br /&gt;
&lt;br /&gt;
: &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://www.rfc-editor.org/rfc/rfc&amp;lt;/nowiki&amp;gt;&amp;lt;var&amp;gt;&amp;lt;document number&amp;gt;&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt; (only if {{para|Style}} is &amp;quot;html&amp;quot; or &amp;quot;empty&amp;quot;)&lt;br /&gt;
: &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://www.rfc-editor.org/info/std&amp;lt;/nowiki&amp;gt;&amp;lt;var&amp;gt;&amp;lt;document number&amp;gt;&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt;&lt;br /&gt;
: &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://www.rfc-editor.org/info/bcp&amp;lt;/nowiki&amp;gt;&amp;lt;var&amp;gt;&amp;lt;document number&amp;gt;&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt;&lt;br /&gt;
: &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://rfc-editor.org/in-notes/ien/ien&amp;lt;/nowiki&amp;gt;&amp;lt;var&amp;gt;&amp;lt;document number&amp;gt;.txt&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt;&lt;br /&gt;
: &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://rfc-editor.org/in-notes/museum/RAREreports/rtr&amp;lt;/nowiki&amp;gt;&amp;lt;var&amp;gt;&amp;lt;document number&amp;gt;.txt&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt;&lt;br /&gt;
&lt;br /&gt;
The HTML rendering of [[Internet Draft]] (I-D) pages can be requested via {{para|Style|html}} (technically any value that is not empty or &amp;quot;text&amp;quot;). This produces the following URL:&lt;br /&gt;
&lt;br /&gt;
: &amp;lt;code&amp;gt;&amp;lt;nowiki&amp;gt;https://www.ietf.org/archive/id/&amp;lt;/nowiki&amp;gt;&amp;lt;var&amp;gt;&amp;lt;draft name&amp;gt;.html&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt;&lt;br /&gt;
&lt;br /&gt;
This URL provides a pretty HTML rendering for newer I-D documents, but returns 404 Not Found for the older files.&lt;br /&gt;
&lt;br /&gt;
=== URL anchor generation ===&lt;br /&gt;
&lt;br /&gt;
Anchors are generated for the URL using four parameters:&lt;br /&gt;
&lt;br /&gt;
: {{Para|section|&amp;lt;var&amp;gt;number&amp;lt;/var&amp;gt;}} generates &amp;lt;code&amp;gt;#section-&amp;lt;var&amp;gt;&amp;lt;number&amp;gt;&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt;&lt;br /&gt;
: {{Para|appendix|&amp;lt;var&amp;gt;number&amp;lt;/var&amp;gt;}} generates &amp;lt;code&amp;gt;#appendix-&amp;lt;var&amp;gt;&amp;lt;number&amp;gt;&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt;&lt;br /&gt;
: {{Para|referenceid|&amp;lt;var&amp;gt;id&amp;lt;/var&amp;gt;}} generates &amp;lt;code&amp;gt;#ref-&amp;lt;var&amp;gt;&amp;lt;id&amp;gt;&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt;&lt;br /&gt;
: {{Para|page|&amp;lt;var&amp;gt;number&amp;lt;/var&amp;gt;}} generates &amp;lt;code&amp;gt;#page-&amp;lt;var&amp;gt;&amp;lt;number&amp;gt;&amp;lt;/var&amp;gt;&amp;lt;/code&amp;gt;&lt;br /&gt;
&lt;br /&gt;
The template will give priority to the first of the parameters: {{Para|section}}, {{Para|appendix}}, {{Para|referenceid}}, or {{Para|page}} in this order and create an anchor using the first matching parameter.&lt;br /&gt;
&lt;br /&gt;
== See also ==&lt;br /&gt;
&lt;br /&gt;
* {{Tl|Ref RFC}} &amp;amp;ndash; pre-populated citations&lt;br /&gt;
* {{Tl|IETF RFC}} &amp;amp;ndash; direct links to RFCs&lt;br /&gt;
&lt;br /&gt;
== References ==&lt;br /&gt;
&lt;br /&gt;
{{Reflist|2}}&lt;br /&gt;
&lt;br /&gt;
== Further reading ==&lt;br /&gt;
&lt;br /&gt;
* {{Cite IETF |title=Internet official protocol standards |rfc=5000 |std=1 |date=May 2008 |publisher=[[Internet Engineering Task Force|IETF]] |access-date =November 2, 2009 |doi=10.17487/RFC5000 }}&lt;br /&gt;
* {{Cite IETF |title=Not all RFCs are standards |rfc=1796 |last1=Huitema |first1=Christian |authorlink1=Christian Huitema|last2=Postel |first2=Jon |authorlink2=Jon Postel |last3=Crocker |first3=Steve |authorlink3=Steve Crocker |date=April 1995 |publisher=[[Internet Engineering Task Force|IETF]] |access-date=November 2, 2009 |doi=10.17487/RFC1796 }}&lt;br /&gt;
* {{Cite web |url=http://www.livinginternet.com/i/ia_rfc_ref.htm |title=Related RFC&amp;#039;s, BCP, FYI, IEN, RTR, STD |access-date=November 2, 2009 |last=Stewart |first=William |website=livinginternet.com }}&lt;br /&gt;
&lt;br /&gt;
{{Citation Style 1}}&lt;br /&gt;
{{Wikipedia referencing}}&lt;br /&gt;
{{UF-COinS}}&lt;br /&gt;
&lt;br /&gt;
&amp;lt;includeonly&amp;gt;{{Sandbox other|&lt;br /&gt;
| &amp;lt;!-- Categories below this line, please: --&amp;gt;&lt;br /&gt;
[[Category:Citation Style 1 specific-source templates]]&lt;br /&gt;
[[Category:Computer networking templates]]&lt;br /&gt;
[[Category:Specific-source templates]]&lt;br /&gt;
[[Category:Templates generating COinS]]&lt;br /&gt;
}}&amp;lt;/includeonly&amp;gt;&lt;/div&gt;</summary>
		<author><name>Wikipedia&gt;GKNishimoto</name></author>
	</entry>
</feed>